ColorData

From PangaWiki
Jump to: navigation, search
ColorData icon. Icon was created by DesignContest. License: Creative Commons Attribution-Share Alike 3.0 License. This means that you can freely use these icons for any personal and commercial purposes (software interfaces, online services, blogs, templates etc.). However, you should include a link to http://www.designcontest.com in your credits.

The software ColorData is a tool to create PANGAEA import files from color data files produced by the AWI XRF scanner. ColorData is distributed as freeware for the operating systems Microsoft Windows, Apple OS X and Linux.

Developer and contact: Rainer Sieger. The software is provided as freeware without warranty by the Alfred Wegener Institute for Polar and Marine Research (AWI).

Download the program for

The current version of ColorData.


Contents

Installation

Download the current version of ColorData to your computer.

Windows

  • Double-click ColorData_Win.exe and follow the instructions.

OS X

Open the downloaded dmg file with a double-click. Drag and drop the file ColorData.app onto the appliction folder icon.

Linux

Uncompress the archive to your user bin directory. Double-click ColorData.sh.

Menu Tools

Set options dialog

Create makefile

Creates a makefile (or control file) from a list of color data files.

Select one or some color data files with the file open dialog (File > Open...) or with the folder dialog (File > Select Folder...). Dragging files onto the program window is also possible.

Choose Tools > Create makefile. The save file dialog asks for the name of the makefile. The name of the file is free.

Create color data import file

Create a makefile first. After editing the makefile, choose this file and set the creation options with the option dialog. Click on OK produces a color data import file. A color data import file can be opened by Excel or by PanPlot. An example is shown here.

Menu File

The work with the XRF Core Scanner on sediment cores starts with the creation of directories on the control PC. For each core a work directory will be created. A linescan images directory as a sub-directory of the work directory will also be created. This work can be done by the program ColorData.

Core directory dialog

Create one core directory

With a dialog the user can set the name of the principal investigator for this core, the core label, and the base directory. Clear deletes all entries.

Some hints from the AWI data curator:

  • The principal investigator should be the working group leader (Tiedemann, Gersonde, Kuhn, Lamy, Matthiessen). Avoid nicknames.
  • The core label has to be the official label given in the cruise report. For cores from Polarstern the list of each cruise can be found here.
Core directories dialog

Create many core directories (file based)

The creation of more than five directorys by using Create one core directory can be a hard work. In this case it is better to create a file with two columns. The name of the first column is free. The second column must be labeld with PI or Verantwortlich. More columns can be followed. The file must be saved as a tab-delimited text file (in German: Text (.txt) - Tabstopp getrennt).

With a dialog the user can set the name of the principal investigator for this core (if not given in the core list file), the base directory, and the file containig the list of cores. Clear deletes all entries.

Personal tools
Namespaces

Variants
Actions
Navigation
specials
Toolbox